日本総代理店
   合資会社エクレシア
   TEL 0422-40-0344 / FAX 0422-40-0348
   sales@ekklesia.co.jp


OpTaliXについて
 OpTaliX
 機能一覧
 ファイルコンバート
 価格・発注方法
 お問合せ

ユーザ・サポート
 サポート・サービス
 セミナー
 よくある質問 (FAQ)
 バージョン履歴
 ニュースのバックナンバ

ダウンロード
 ソフトウェアとマニュアル
 カタログ
 デモ版

ユーザの集う掲示板
 掲示板

Optenso社サイト
 Optenso

その他の情報
 会社案内
 参考書籍
 WEB Policy
 リンク




OpTaliX バージョン履歴 (2003年〜2005年)

最新のバージョン履歴はこちら
日本語リファレンスマニュアルのバージョン履歴はこちら

Version 6.28
(2005年12月19日)
  • コーティングの厚さ方向に沿った屈折率の分布を COA PRO コマンドで表示できるようになりました。
  • 基準となる任意のガラス(ベースガラス)にと類似の屈折率/アッベ数をもつ代替ガラスの一覧表を表示できるようになりました。
    LIS ALT (LISt ALTernative) コマンドです。
  • マクロまたはコマンドラインでの変数設定がハンドル名に拡張されました。
  • 2文字からなるコマンドが、ズーム系において適切に設定できない場合がありましたが、修正されました。
  • マクロにおいて IF-ELSE-ENDIF 構造を設定した際、大文字/小文字が混在していると意図どおりの動作ができませんでしたが、修正されました。
Version 6.26
(2005年11月27日)
  • ピックアップに関する機能を大幅に強化しました。ピックアップをグループ単位に行えるだけでなく、ティルトやディセンター、 非球面係数については独立個別にピックアップできます。
    たとえば、 任意の面間において XDEだけにピックアップを設定し、その他の偏芯パラメータには何らの制約関係をもたせないという 指定が可能です。これと同じことが、非球面係数のピックアップにおいても適用できます。
    上記機能の拡張に伴い、コマンド CPI, DPI, API, TPI, MPI は OpTaliX の正規の機能としては廃止されました。 (しかし、過去に保存されたデータとの互換のため依然として動作はします。) これらに置き換わるコマンドはPIK XXX コマンドです。
  • 新しく、 Diamond (ダイアモンド) が材料データベースに加えられました。
  • シーケンシャルモードにおいて TIR (全反射面) の指定がなされている場合には常に屈折率比 n/n' がチェックされるように改良されました。 屈折率比は GL1 および GL2 によって定義されます。 従来は、空気界面においてのみ、チェックが機能していました。
Version 6.25
(2005年10月30日)
  • コーティング・データのファイル名を 256文字まで対応できるように拡張しました。この文字数には、パス名も含まれます。
  • 面の識別子として 新たに "g" を追加しました。この識別子を使えば第s面上の光線座標のを出力を、"g"によって示される面の座標系で行えます。
    例えば、"Y s2 f4 g3" と指定するのであれば、第2面上の光線座標は、第3面の座標系を使ってなされます。
  • Code V の SEQ データを読み込む際、ズームデータに対する対応力が拡大に向上しました。
  • ノンシーケンシャル(NSS) のパラメータの設定時に、NSS範囲との対応が適切であるかをチェックし、 不整合があればメッセージが出力されるように改良されました。
  • レンズカタログの内容を、更新しました。
Version 6.22
(2005年10月9日)
  • スプレッドシート・タイプのエディタ(例えば面エディダ、コーティングエディタなど)の入力欄の幅を、 ユーザが任意に変更できるようになりました。入力欄のタイトル境界をドラッッグしてください。
  • ズームエディタにアイコンを増設しました。ポジション番号の変更や、ズームパラメータの追加、ヘルプの表示などが、いっそう簡単になりました。
  • レンズパラメータ(曲率半径や非球面係数など) を対話式に変化できるスライダー・バーを設けました。 メインメニューの Tool から、Slider Control とたどってください。評価結果(光路図、横収差図など)が表示されていればその出力もリアルタイムで変化します。
  • マクロで、IF-THEN-ELSE 構文が使えるようになりました。
  • GL2 コマンドが プライベートガラスにも対応しました。
  • SPS ODD や SPS XYP の係数を自動設計の変数する際、コマンドラインからの設定が受け付けられませんでしたが、修正されました。 スプレッドシートからの設定も引き続き可能です。
Version 6.21
(2005年9月25日)
  • テキストウインドウの内容検索の機能と、プリント機能を追加しました。
    その他、内部的な改良を施しました。
Version 6.20
(2005年9月18日)
今回は保守を目的としたアップデートです。
  • 光線追跡の初期条件を整える機能 (ray aiming) に改良を施しました。
  • マクロの数式表現に関する文法処理に修正を加えました。
Version 6.18
(2005年9月11日)
  • 光学系の3次元描画において、レンズエッジの描画能力を向上させました。
  • CodeV の SEQ ファイルからのインポートにおいて、ガラスがズーム化されている場合にも対応しました。
  • 照明解析において、光線の分布評価処理を改良しました。
  • 照明解析において、ズームポジションを考慮するように改良されました。
  • WAVコマンドによる波面収差の RMS表現において、波面のティルトを除去した表示も可能としました。
  • ガラスデータベースに登録されていた 水晶・石英・サファイアの線膨張係数を修正しました。
  • ショット(Schott)社のガラス P-PK53, P-SK57, P-LASF47 を登録しました。
Version 6.16
(2005年8月21日)
=修正アップデート=
  ズームエディタから、複数のズームポジションを連続して挿入するとOpTaliX が
  異常終了するエラーを修正しました。

=お知らせ と お願い=
  このバージョンをもって、フローティング・ウインドウのサポートを終了いたします。
  今後は、メインウインドウの内部に、他のすべてのウインドウが含まれる
  "インサイド・ルート・ウインドウ"のみをサポート致します。
  何卒、ご了承のほどお願い申し上げます。
Version 6.15
(2005年8月14日)
  • 非球面量のプロット(ASDコマンド) の表現方法に改良を加えました。
  • ISO図面描画において、ミラー面に続くエレメントの前後が逆に表示されていましたが、修正されました。
  • システムデータの定義ウインドウ (configuration dialog) を他の複数のウインドウと同時に起動すると、 プログラムが異常終了することがありましたが、修正されました。
Version 6.14
(2005年7月31日)
=新規機能および仕様変更=
  • Schott 社のガラス N-SF14, N-LASF46A が追加登録されました。
  • 面/視野/波長/ズームポジション を特定するための修飾子に、ユーザ定義変数を組み合わせられる様に改良されました。 例えば、第2面 を示すために "s2" (入力の際には"記号は不要)とする代わりにユーザ定義変数を使って、
      $x = 2
      thi s$x ...
    の様に記述できるということです。
    つまり、修飾子 "s" と変数 $x の値(ここでは2) を結合させて全体として "s2" という意味を持たせられるということです。 この機能は、特にマクロと組み合わせて使うと有用です。
    次の例は、視野角(yan) を等間隔に設定するためのマクロです。
      do $x = 1,3
      $angle = 2*$x
      yan f$x $angle
      enddo
  • 各面の有効径に いくらかの余裕を自動的に加えて描画する機能が改良されました。 従来は各面の光線有効径を定数倍することしかできませんでしたが、このバージョンからは光線有効径を 加算する方法も選択できるようになりました(いずれの場合も描画径に影響を与えるだけで、光線追跡そのものには関係しません)。 この機能は、メインメニューの File から、Preferenceを選択し、operations タブを選ぶと開くダイアログで設定できます。
  • 非球面量のプロットにおいて、ワイヤグリッドおよび等高線(コンター)いずれにおいても2次元表示ができるように改良されました。 従来は放射方向に沿った描画しかできませんでした。この機能は、メインメニューから Manufacturing を選び、Aspheric Deformation -> as 2D surface deviation と たどることで起動できます。 コマンドラインからは "ASD2 ?" と入力します。
  • 膜材料エディタが、1材料あたり 600点のデータ、つまり 600波長に対する 複素屈折率 N=(n,k) を登録できるように拡張されました。 従来は 100点までに制限されていました。
=不具合の修正=
  • 面エディタの非球面タブで、非球面形状のピックアップ指定(Pik)を設定する際、数字以外の文字が入力されるとプログラムが異常終了していましたが、修正されました。
  • MTF FLD の評価時、視野の総数が11を越えると MTF評価結果の内挿処理に不具合が生じ、プログラムが異常終了することがありましたが修正されました。
Version 6.10
(2005年7月4日)
=新規機能および仕様変更=
  • ビネッティングを発生させている面の番号が、視野点ごとにSET VIG コマンドで確認できるようになりました。
  • Wolf-Optik 社 (ドイツ) のニュートン原器がリストに加わりました。
  • 面エディタで選択されている面が、レンズ断面図上で青色に表示されるように仕様変更されました(preferenceで設定が必要です)。
  • 下記ガラスが、カタログガラスとして追加されました。
    Schott : N-FK51A, N-LASF31A, N-SF11
    Ohara : L-LAH81, L-LAM72, S-BSM21, PBH55, PBH56, LAH80,S-TIH20,CERAM-Z, CERAM-ZHS
    Corning : C7056
  • Grintech社の シリンドリカルGRINレンズが、カタログに追加されました。同社の動径GRINは、GRT というコードで識別されていましたが、シリンドリカルGRINの識別コードは GRCです。
=不具合の修正=
  • MTF vs 空間周波数 の出力において、適用波長が2波長のみの場合には、波長重みが適切に適用されていませんでしたが、修正されました。
  • コーティングの最適化機能において、目標関数が100を越えると異常終了していましたが修正されました。
  • 幾何光学的MTF の デフォーカス依存性の出力ウインドウを拡大縮小すると、OpTaliXが異常終了していましたが、修正されました。
  • コーティング材料エディタが、1つ目に登録されたプライベート材料を受け付けない状態となっていましたが、修正されました。
Version 6.06
(2005年6月5日)
  • IC コマンドが追加されました。 IC YES|NO の切り替えにより、光線と面の幾何的交点(通常2つ存在)のうち、他方の交点を選択できるようになりました。
  • CodeV の SEQファイルとの import/export においで、IC コマンドが認識されるようになりました。
  • ArcherOpTx社製の全カタログ製品を OpTaliX に取り込めるようになりました。
  • 透過率解析 (TRAコマンド) における各面の透過率の寄与をプリントする際、偏光方向が考慮されるようになりました。 以前のバージョンでは 常にS成分とP成分の透過率平均が出力されていました。
  • 像面の照度分布解析 (RIRRコマンド) において、材料吸収と反射損失の影響が適切に扱われるように改良されました。
  • 幾何光学的なエンサークルド・エネルギー計算 (RADコマンド) がデータベースアイテム (LDI) に正しく反映されるように改善されました。
  • NRD > 32 の条件において、PSF のグレーレベル/疑似カラー解析 においてプロット位置が適切ではありませんでした。 修正されました。
Version 6.05
(2005年5月22日)
  • 瞳の分割数が少ない状況 (NRD<32) における波動光学的なMTFの精度が著しく向上しました。
  • 最適化のための variable/targets エディタが、モードレスタイプのウインドウに変更されました。 このことにより、このウインドウを閉じることなく他の作業、例えば 収差の評価や近軸量の確認など行えるようになりました。
  • OpTaliX を操作する際の一貫性を向上させるため、デフォーカスを意味する用語やコマンドを "thi si" に統一しました。 従来は "DEF" が採用されていました。
  • レンズモジュール(MOD) に 倍率設定の機能が追加されました(MRDコマンド)。これまではゼロ倍のみが仮定されており、その状態(レンズモジュールへの入射光束が平行光束) においてのみ、無収差レンズとして振る舞っていましたが、このバージョンからは任意の倍率における無収差レンズを定義できます。
  • CodeV の SEQ ファイルを import/export する機能が次のとおり拡充/修正されました。
    • CodeV と OpTaliX における PIM および THI SI に関する表現上の差違を考慮して、 的確にコンバートされるように改良されました。この結果、import/export にあたって、像面位置の設定に差違がなくなりました。
    • 画角に関して定義された描画色は、それが明示的に定義されている場合のみ export されるように変更されました。
    • PUI, PUX, PUY, MRD が正しく import/export されるように修正されました。
  • Zemax ファイル のimport/export 機能が次のとおり修正されました。
    • Gradient Lens Corp. (GLC) 製の 屈折率分布が正しく変換されるように修正されました。
  • コーティングの最適化において、ターゲットの挿入・削除・並べ替えが行えるようになりました。
Version 6.04
(2005年5月2日)
  • BMP,PCX,PNGファイルへのグラフィクスのカラー出力において、再現色が不足していました。 24bitカラーに修正されました。
  • レンズ材料がピックアップされている場合、環境解析においてプログラムが異常終了していましたが、修正されました。
  • CodeV のコントロールコード KC,AC,BC,CC,DC,EC,DC,GC,HC の互換性を正しくインプリメントしました。
Version 6.03
(2005年4月22日)
  • 自動設計におけるガラス選択範囲を制約するために使われる GLP コマンドの解釈に不備がありましたが、修正されました。
  • ユーザ定義変数 ($variable) のマクロ中における動作速度を改善しました。
Version 6.02
(2005年4月15日)
今回のアップデートは レポートされた不具合の修正版です。
  • 曲率半径に関する公差解析(感度解析=sensitivity analysis) において、対象となる面が平面の場合、適切な解を生成できていませんでしたが、修正されました。
  • コーティング・エディタにおいて、層の挿入削除の際、膜厚のピックアップが移動していませんでしたが、修正されました。
  • グローバル参照面におけるティルトおよびシフトのピックアップが面エディタから正しく更新できませんでしたが、修正されました。
  • 物体距離がぴったりゼロの場合には、HMY, UMY, HCY, UCY が "NaN" (Not a number) エラーが発生していましたが、修正されました。
  • LAYコマンドにズーム識別子 "zk" を指定しても、常に第1ポジション (z1) の値を返していましたが、正しくポジションを取り扱うように修正されました。
Version 6.00
(2005年3月31日)
  • DISX がデータベースアイテム(LDI)として利用できなくなっていましたが修正されました。
  • 3次収差がズーム指定子を受け付けていませんでしたが修正されました。
Version 5.99
(2005年3月25日)
  • 最適化処理におけるガラス制約条件 (GLP) が、その他の制約条件と共にレンズデータの一部として保存されるようになりました。
  • 主点位置 SH1, SH2 がデータベースアイテムとして利用できるようになりました。
  • レンズ面上にコーティングを貼り付ける操作を 面エディタ上で実行すると OpTaliX がクラッシュする症状が発生していましたが、修正されました。
  • 正しい書式で CLS コマンドを入力しても エラーメッセージが出力されることがありましたが、修正されました。
  • エディタに数値を設定した際、11文字以降が無視されるという症状が version 5.94 と 5.98 に現れていましたが、修正されました。
  • スポットダイアグラム および ファンカーブにおいて、図のスケールとして負の数値を設定すると、逆符号で収差描画がされていましたが、修正されました。
  • 設定波長がただひとつ (単色) だけ設定された状態で PSF TRU (点像分布関数のトゥルーカラー表示) を実行すると OpTaliX がクラッシュしていましたが、修正されました。
Version 5.98
(2005年3月16日)
  • 構成エディタ(Configulation Editor) におけるスペクトル選択機能 (OSP) が改良されました。
  • 設定帯域端における波長重みを適切に設定するためのスケールバーが用意されました。
  • スポットダイアグラムのマーカーサイズ(各光線と評価像面の交点のプロットマーク)のサイズを、 Preference の "Misc" タブで設定できるようになりました。 一時的なサイズ変更の場合には新設の SPMS コマンドで変更できます。
  • コーティングの機能について、いくつかの改良が施されました。
    • 最適化のための 目標関数ダイアログのサイズを変更できるようになりました。
    • 膜構成をファイルに保存する際、ファイルの拡張子が省略されているならば "OTC" が付与されるようになりました。
    • 膜構成の保存/読み出しの対象となる 作業ディレクトリを変更した際、 その状態が維持されるように改良されました。以前のバージョンは、必ず所定のフォルダにリセットされていました。
    • 膜厚を最適化の変数にした状態で、新たな層の挿入や 削除を実行した際、それにともなって変数フラグが移動しないという不具合がありましたが、解消されました。
    • 膜材料および膜厚をピックアップできるようになりました。この機能により、繰り返し構造(λ/4膜のスタック構造など)を持つ膜の設計が著しく容易になりました。
  • 現行バージョン(今回のアップデートの直前のバージョン)のアップデートにおいて発生していたいくつかの面エディタ関連の不具合を解消しました。 しかし、まだ (マイナーではありますが) 何点かの不具合が残されています。これらは次版で解消いたします。
Version 5.97
(2005年2月20日)
  • CodeV あるいは Zemax, Oslo で作成したレンズデータをインポートする際、OpTaliX が認識できなかったコマンドの一覧を、 $i\temp\inort.log ファイルに出力する機能が追加されました。
  • CodeV の SEQ ファイルからのインポート、あるいは SEQ ファイルへのエクスポートにおいて "CLS FLD" による視野色の定義が正しく変換されるように改良されました。
  • ズーム光学系において、円錐係数(K) ならびに高次の非球面係数(A,B,C,D..) が最適化変数として正しく認識されていませんでしたが、修正されました。
  • 面エディタや、コーティングエディタのように、大きなグリッドをもつダイアログのスクロール速度を改善しました。
  • 各種エディタウインドウにおいて、その画面をスクロールバーでスクロールする際、従来はマウスボタンを離した時点で初めて画面が更新されました。 本バージョンからはスクロールバーの操作に対してリアルタイムで画面が更新されるように改良されました。
  • サイズ変更が可能なエディタウインドウの右下端には、"サイズ変更グリップ記号" が表示されるようになりました。 これにより、サイズ変更の可否が容易に判別できるようになりました。
  • エディタウインドウにおいて、複数のセルを同時に選択できるようになりました。マウスのドラッグのみならず、シフトキーと矢印キーの同時押下も受け付けられます。
  • テキストウインドウ(Text window) および 履歴ウインドウ(History Window) に出力される文字サイズの変更は、従来よりOpTaliX のメインメニューの File からPreference を 選択すると開くダイアログの [window] タブで指定できるようになっていましたが、それを反映するには、OpTaliX の再起動が必要でした。 しかし、本バージョンからは再起動を要せず、直ちに反映されるように改良されました。
  • ファイルのパス名として 256文字までを受け付けるように改良されました。従来は128文字までに制限されていました。
  • ユーザ定義グラフィクス (UGR:User-defined Graphics) において、幾種類かの関数とコマンドが正しく認識されていませんでしたが、修正されました。
Version 5.94
(2005年2月3日)
  • 波長数を変更した際、MTFの計算結果が正しく更新されない場合がありましたが修正されました。
  • MTF特性図をグラフ出力する際、計算点を内挿する関数として従来はスプライン関数を使っていました。しかし、オーバーシューティングが大きく、 時として負のMTFが提示されることがありました。そこで、内挿関数を "Akima" 関数に変更し、これらの症状を大幅に軽減させました。
  • OSPコマンドによる光学スペクトルの内挿もまた、"Akima" 関数を用いるように変更されました。 これに伴い、スペクトル分布が、オーバーシューティングの影響を受けず、適切に近似されるようになりました。
  • 視野情報に関連したプロット、およびコーティングのプロットにおいて その描画色の設定機能を大幅に改善しました。 また、これらを CLS FLD コマンドや CLS COA コマンドを使って、コマンドラインから設定できるようにもなりました。
  • PSF XY による点像分布関数を 規定のファイル(\optalix\temp\psfxy.txt) に保存できるようになりました。
  • WAV コマンドによる波面収差の解析に、本来は設計時のみ考慮されるべき 開口重み (WAT) が反映されていました。 このバージョンにおいて、WTA の設定が設計時のみ考慮され、解析には反映されないよう、正しく修正されました。
Version 5.91
(2005年1月14日)
=改訂・修正箇所=
  • 温度環境解析において、空気の屈折率の温度依存性が正しく設定されない場合がありましたが、修正されました。 この不具合に関連した光学評価への影響は非常に小さく、ほとんどの用途において再評価の必要は生じません。
  • コマンドラインからズームパラメータの値を変更した場合、ズームエディタおよび面エディタに適切に反映できない場合がありましたが、修正されました。
  • いくつかの図表出力において、軸のスケールが表示されていませんでしたが修正されました。
  • 膜材料エディタに設定したデータがファイルに保存できない状態となっていましたが、修正されました。
Version 5.90
(2005年1月4日)
=新機能=
  • ズームポジションをコマンドラインから 追加、削除、コピーできるようになりました。 "INS Zi..j" , "DEL zi..j" および "COP Zi..j" の各コマンドをお使い下さい。
  • コマンドラインから、ズーム化されたパラメータの値をポジションごとに個別に変更できるようになりました。 従来はすべてのポジションに対する値が一括して同じ設定値に変更されるか、あるいは個別設定の場合にはズームエディタを用いるしかありませんでした。
  • 光学薄膜(コーティング)の透過率/反射率特性図に、設計目標値もプロットされるようになりました。
  • コーティング用の材料 (膜材料) の新規定義、編集、削除を、専用のダイアログで簡便に行えるようになりました。 コマンドラインからの起動は、"EDI CMAT" コマンドです。GUI からも利用できます。
  • アパーチャの属性として、HOLE (穴)を設定できるようになりました。この設定を行えば、HOLEの内側に光路を取る光線は追跡されなくなります。 カセグレン光学系の主鏡を設定する際などに便利です。この機能は通常のシーケンシャルな面のみならず、ノンシーケンシャルな面に対しても有効です。
  • 任意の開口形状を ビットマップファイル (BMP,PCX,PNGファイル) から設定できるようになりました。この機能は、 "INT" オプションを用いて利用できます。
  • 照明解析に関わるデータが、レンズデータとともにファイルに保存されるようになりました。
  • CODE V (tm) の SEQ ファイルのやりとり (import/export) において、座標のグローバル参照がサポートされました。
=改訂・修正箇所=
  • 最適化の制約条件を設定するために面番号が参照されている状態で面の挿入・削除が実行されると、 制約条件の定義データが失われる場合がありましたが、修正されました。
  • SPS/UDS に表記される係数が、最適化の終了後に更新されていませんでした。修正されました。
  • 最適化の変数として、ZDEが認識されないという不具合がありましたが修正されました。
  • ノンシーケンシャル面中にHologram 面を定義した場合、光路長が正しく計算されていませんでしたが、修正されました。
Version 5.85
(2004年11月25日)
=新機能=
  • OpTaliX-LTバージョンも、Pro版と同様に日本語ヘルプが実装されました。
  • "ECHO Y|N" コマンドが新設されました。"ECHO Y" が設定されると、以降、コマンドラインからの入力文字列がそのままテキスト出力ウインドウに反映(出力)されます。
  • 他社製の薄膜設計ソフト、TFCalc で生成した膜データをインポートする機能が新設されました。
  • FIEコマンドが新設されました。これは、非点収差およびディストーションと(オプション設定により)球面収差図を、1枚の図表に配置したものです。
  • 全系の透過率解析において、MgF2 の単層コートをデフォルト膜として設定する機能を追加しました。
=改訂・修正箇所=
  • 4分割ディテクタ解析 (QUA) の出力ウインドウに、"矢印アイコン" が追加されました。 このアイコンをクリックすることで、異なるズームポジションに対する解析結果の表示が簡単に実行できます。
  • 面エディタにおいて、面タイプの設定が面番号と共にラベルとして表示されるようになりました(非球面タブ、偏芯タブ等を選択しているとき)。 この結果、それぞれのタブで着目すべき面を識別しやすくなりました。
  • ズームエディタを使って追加のズームポジションを挿入した際、そのポジションに対するパラメータとして、挿入直前のポジションのパラメータが埋められるように 変更されました(ポジション確保および既存パラメータからのコピー)。 従来は、ポジション確保のみが実行され、パラメータは空欄(ゼロ)のままでしたので、不要なエラーが誘発されることがありました。
  • コーティングの最適化において、膜厚が容易に負になるという指摘を頂戴していました。 この傾向を軽減するため、内部的に生成される不等号制約条件(膜厚 > 0) に対する重みを増加するように設定を変更しました。
  • DXFへの図表出力が適切に行われない場合(位置ズレ等)がありましたが、修正されました。 しかし、まだ完全ではなく、ケースによっては適切でない描画をすることもあります。これらについては引き続き修正しています。
  • 面エディタのサイズを変更した後、面の挿入を行うと OpTaiX 全体が異常終了していましたが、修正されました。
  • 最適化機能において、最小化の目標値をユーザ定義関数で表現した場合に、目標値が常に "ゼロ" と認識されていましたが、正しく認識されるように修正されました。
Version 5.82
(2004年11月14日)
=新機能=
  • 像面におけるゴーストの影響を、リアルに表現できるようになりました。この解析には、ゴーストに関連する すべての面の組み合わせが考慮されます。もちろん、コーティング、吸収、ビネッティング(ケラレ)等も考慮されます。 ただし、鏡筒の内面反射は考慮されません。詳細は、マニュアルの "GHO RGB" コマンドの章をご覧ください。
  • 非点収差、ディストーション、縦収差の評価が像回転を伴う光学系(例えば偏芯光学系)にも対応しました。 (横収差、スポットダイアグラム、波動光学的評価等は従来より対応していました。)
  • GHVコマンドによるゴースト解析において、単光線追跡も機能するように改良されました。
  • 非球面形状の解析機能(ASDコマンド)が面の法線に関する情報も出力するように改良されました。
  • シングルモードおよびマルチモードファイバのモードフィールドを計算しそれをビジュアルに表現する機能が追加されました。 この機能を使って計算したモードフィールドを結合効率の計算に適用することもできます。詳しくは、マニュアルの "MMFコマンド" の章をご覧ください。
  • LM最適化における収差の数(SPDを目標関数に設定した場合であれば、光線本数そのもの)に制限がなくなりました。従来は 10000 本までのサポートでした。
  • スプレッドシートから編集可能なポジションの上限が 50に拡張されました。これを越えるポジションを指定する場合は、 コマンド入力による設定によります。コマンド入力は、コマンドラインから直接入力するほか、"ZEDコマンド" によって エディタを起動することで行います。この場合のポジション数には制限がありません(実際にはお使いのPCのメモリで上限が決まります)。
  • ATYコマンドのオプションパラメータの指定順序の制限がなくなりました。一例として、ATY S3 ODD9 でも、 ATY ODD9 S3 でも受け付けられます。
  • メニューバーから [Display] - [Plot a single ray] によって起動される単光線光線の光路表示機能が、ゴースト光路のプロット機能 (GHVコマンド)にも適用されるようになりました。
  • 4分割ディテクタの解析機能 (QUEコマンド) が追加されました。
  


ゴースト解析の新機能。すべての
面間の1回繰り返し反射の組み
合わせについて、コーティング、
材料吸収、ビネッティングの影響
を考慮した評価がビジュアルに
表現されます。

=改訂・修正箇所=
  • CodeVのSEQ形式のデータに関するインポート/エクスポートにおいて、グレーティングのパラメータが適切に 変換されていませんでしたが、修正されました。
  • ビーム伝播解析(BPR)において、OpTaliXに内蔵されたファイバデータのモードフィールドが正しく計算されていない場合がありましたが、修正されました。
  • 縦の球面収差図が不適切な結果を表示することがありましたが、修正されました。縦の球面収差量を表示するコマンド "LAX,LAY" についても同様です。
  • 最適化オプションが、ユーザ定義変数と不等号制約条件との組み合わせを受け付けないという問題がありましたが、修正されました。
  • 最適化におけるデフォルトの制約条件のうち、MXT,MNT,MNE を指定しても機能していませんでしたが、修正されました。
  • 像界が空気以外の媒質で占められている場合、RED が正しく機能していませんでしたが修正されました。
  • 反射面を含む光学系において、透過率解析が正しく機能していませんでしたが修正していました。
  • 外部ファイルからの面のコピー挿入が正しく行われないケースがありましたが修正されました。
  • 溶解ガラスの適用波長範囲が実際よりも狭く登録される不具合がありましたが、修正されました。
=既知の不具合=
  • 面エディタおよびズームエディタのウインドウサイズを変更した後、行の挿入(面の挿入やズームポジションの追加)を行うと、 OpTaliX が異常終了します。この問題は、次回のバージョンアップで修正されます。 当面の回避方法としては、行の挿入前にいったんウインドウを閉じ、再度開いて頂く方法があります。ウインドウのサイズを変更しない限り、この問題は発生しません。
Version 5.76
(2004年9月26日)
  • マクロ機能が大幅に強化されました。ユーザ定義変数および関数がループ構造と組み合わせて利用できるようになりました。
  • EIMD および PSF の出力画面に、ズームポジションに渡るブラウズが可能になりました。また、EIMD については より詳細な入力パラメータの設定が可能になりました。
  • ファン光線の出力符合が物体距離の符合に依存するという不具合がありましたが、依存することなく定義どおり出力されるように修正されました。
  • 面の前後の入れ替え (INVコマンド) を実行すると、ホログラフィックな面の係数および SPS の係数の一部が失われるという不具合がありましたが修正されました。
Version 5.75
(2004年9月11日)
  • オンラインヘルプが日本語対応になりました。メニューバーの [?] アイコンをクリックすれば、 ヘルプメニューが表示されます。また、各ダイアログの [HELP] ボタンをクリックすれば、そのダイアログに関連したヘルプが表示されます。
  • レンズデータをファイルから読み込んだ後、最適化のための光線グリッド数が更新されていませんでしたが修正されました。
  • マルチモードファイバの結合効率計算において、最後に計算した送受信モードペアの効率が、計算に用いた 全モードを考慮した合算値の代わりに表示されていました。これは全モードペアの単純平均値が表示されるように修正されました。
  • AF機能において結合効率を評価関数とする指定、"AF CEF" が利用できなくなっていましたが修正されました。
  • サイズ調整可能なダイアログボックスの位置が意図しない場所に移動する事象がありましたが修正されました。
Version 5.73
(2004年9月6日)
  • プログラム規定値に変更に関連して、『レンズデータを読み込む直前に旧データを表示しているコマンドをすべてクローズするためのチェックボックス』が新設されました。
  • レンズデータベースアイテムとして、ASTT(非点/タンジェンシャル)、ASTS(非点/サジタル)、ASTD(非点隔差)が追加されました。
  • ズームレンズの RIRR(相対像面照度比)図出力に、ポジション番号が表記されるように改良されました。
  • 面間隔を絶対値ではなく 増分で指定するコマンド TIN を新設しました。また、パワーを増分で指定するコマンド CIY を新設しました。
  • RIRR (相対像面照度比)がマニュアルの記述どおり、第1視野点に対して正規化されるように修正されました。
  • マルチモードのカップリング効率計算において、送信側・受信側のファイバともに計算の対象するモード番号の上限を設定できるようになりました。
  • レンズ断面図の描画において、仮想面の表示を抑制するためのオプションが追加されました。
  • 2番目以降のズームポジションについて、MTFのデフォーカス特性図が出力できていませんでした(常に第1ポジションが出力されていました)が、修正されました。 また、ズームポジションを切り替えて表示するための矢印アイコンを、表示ウインドウのツールバーに設けました。
  • 非球面のタイプの変更をコマンドラインから実行した際、それが面エディタの表示に反映されていませんでしたが、修正されました。
  • 倍率の色収差図(LAC)において、波長を表示するラベルが正しく表示されない場合がありましたが修正されました。
  • GRINレンズの URN 設定において高次項の入力ができないという問題がありましたが修正されました。
  • 最適化の制約関数指定において、x/y/z を指定した際に瞳の通過座標として負の値を指定すると、それが制約値として認識されるという問題がありましたが修正されました。
  • レンズ断面図において、非球面が適切に表示されていない場合がありましたが修正されました。
Version 5.70
(2004年8月22日)
  • 後述の各データ編集ダイアログがサイズ可変に対応しました。ウインドウの境界をドラッグして下さい。サイズが可変となったダイアログ: 面エディタ、コーティングエディタ、ガラスカタログビュア、公差エディタ、ツェルニケエディタユーザ定義面エディタ、コーティングの膜厚エディタ。
  • 指定の画角範囲、ズームポジション範囲に対して求めた各面の光線有効径(半径)を データベースアイテム SD で参照できるようになりました。
  • 村田製作所製の透光性セラミクス LUMICERA をガラステーブルに追加しました。
  • 面エディタに対して、数値の代わりに文字列を入力すると OpTaliX が異常終了することがありましたが、修正されました。
  • カムモード中で さらに "CAM Y" と入力すると ズームデータが失われるという不具合がありましたが解消されました。
  • ティルトしたアレイ面の光線追跡において、ティルトの順序が適切に取り扱われていないという不具合がありましたが、修正されました。
  • その他、細部の改良が実施されました。
Version 5.68
(2004年8月17日)
  • 近軸量の計算に、ツエルニケ面のパワー項(Z4項)が反映されるように変更されました。
  • 幾何的MTFが計算できるようになりました。
  • 光線の描画内容を設定 SET FAN コマンドが パラメータ "XY" を受け付けるようになりました。これを指定すると、X/Z平面および Y/Y面内における光線を同時に描画できます。
  • 索引付きのコンパイル済みHELPファイル(英語版)が添付されました日本語版は、オンラインヘルプともに近日対応予定です。
  • GRIN 材料に対する光線追跡において、材料の厚さが光線追跡のステップ長よりも短い場合であっても、追跡解が発散しないように改善されました。
  • ツエルニケ面における光線追跡精度を向上させました。以前のバージョンではとりわけ長焦点光学系において、波面収差と幾何的収差の間にいくらかの相違を生じる場合がありました。
  • カム計算において、視野情報がステップごとに補間されるように修正されました。
  • 像面照度計算において、次の場合にグラフィック表示が適切に表示されていませんでしたが修正されました。 XRI/YRIで視野指定をした場合。視野指定に負の値が含まれる場合。第1画角が軸上物点でない場合。
Version 5.66
(2004年7月27日)
  • 像座標による視野の定義ができるようになりました。これまでは物体側の画角、物体座標、理想像座標による指定のみが可能でした。 新設のコマンド XRI、YRI または 面エディタを用いて視野の定義を像座標で行えばレンズの構成パラメータを変更した場合でさえ、 所定の評価像面において主光線が設定したどおりの像座標に到達するように物体座標が制御されます。 その際にはすべての幾何収差が考慮されます。
  • RED コマンドは ソルブ(system solve) に変更されました。この結果、たとえレンズの構成パラメータを変更した場合でさえ、光学系の倍率は常に設定した値のとおりに維持されます。 なお、この操作は物体距離の変化によって達成されますが、PIM Y が指定されている場合には同時に像距離も調整されます。
Version 5.65
(2004年7月21日)
  • シフトおよびティルトを持った偏芯光学系に対する光線探査法を改良しました。このことに関連して新しいコマンド、RAIS を導入しました。 このコマンドを使えば 光線探査における最大ステップ幅を調整できます。(光線の探査所要時間にも影響があります)以前のバージョンでは、とりわけ大きな偏芯を持つ光学系において 適切に光線探査がなされない場合がありましたが、これは妥当なステップ幅が設定されていなかったために、光線探査の繰り返し回数が上限値に到達してしまったためでした。 RAISの調整により、このような状況が発生する特殊な状況にも対応できるようになりました。
  • 物体距離を変数とするフラグを 変数設定ダイアログでは設定できるものの、それが面エディタに反映されていませんでしたが、修正しました。
  • ファイバの先端カットに角度をつけるためのコマンド WDX/WDY は、従来バージョンではファイバ全体のティルト(FRA/FRB)に置き換えて計算していましたが、これらは本来は独立したものです。 OpTaliX 5.65 からは先端カットに対応するモードフィールドを正確に取り扱えるアルゴリズムに変更されています。
  • ファイバの結合効率ダイアログボックス(CEF)において、MFRはダイバージェンスの設定変更に伴って自動的に更新されるようになりました。
  • 最近の数バージョンにおいて、ヘルプ文中から他のヘルプへのリンクが機能しない症状が発生していましたが、修正されました。
  • LISコマンドにおけるガラスデータの出力において、DNO/DVO によって屈折率やアッベ数のオフセットが指定されている場合には、MIL-CODE (ガラスコード 例: 516.614) が表示されるようになりました。このことはガラスを変数とした自動設計時に、仮想ガラスに直近の実存ガラスをマニュアルで探査する際の情報取得に便利です。 仮想ガラスを自動的に実存ガラスに変換する、REGコマンドも、引き続き有効です。
Version 5.64
(2004年7月7日)
  • GRINレンズに関して、より広範囲の分布タイプに対応できるように屈折率分布係数の編集機能を拡張しました。
  • Stop面が大きな偏芯を有している場合であっても光線をより的確に探し出すように、光線探査の機能を改善しました。
  • FIRコマンドによる 近軸量の表示機能において、表示書式を変更しました。このバージョンからは、 無限共役に関する近軸量(焦点距離など)と物体距離の設定によって明示的に定義された有限あるいは無限共役における近軸量(共役距離など)を分離して表示します。
  • UGR (ユーザ定義グラフィクス) において、不完全な視野指定(例えば yim f1 とすべきところ、単に yim のみ指定) があっても、それをチェックし修正する機能が追加されました。
  • ズームエディタにおける数値の表記方法を改訂しました。これまではセル幅をこえて不要なゼロを表示する場合があり、それが数値の誤読につながる場合がありました。
    従来バージョン : [12.340000]00 → 横スクロールにより → 12[.340000]
    このバージョン : [12.34 ]
  • logn(x,y) のような多価関数の構文解析を誤る場合がありましたが修正されました。
  • MTFプロットにおいて、視野(画角)情報のタイトルと中身が一致していないケースがありましたが、修正されました。
  • その他、細部の改良および不具合を修正しました。
Version 5.63
(2004年6月22日)
  • 像距離(最終レンズから評価像面) および 像クリアランス(最終レンズの光線有効位置から評価像面)を それぞれ、データベースアイテム IMD および IMC として追加しました。
  • コマンドラインに [Enter]キー だけを入力した際、それが テキスト出力ウインドウに空白行として出力できるようになりました。この機能は、[File] → [Preferences] とたどると起動する ウインドウの "Operations" タブで、"Blank command lines are mirroed in text output window" にチェックをいれた場合のみ機能します。
  • ショット社のガラスカタログを更新しました。
  • 吸収膜(金属膜)を含む多層膜の透過率・反射率計算において、正しい結果の得られない場合がありましたが修正されました。
  • コーティング・エディタにおいて、層の挿入と削除がうまく実行できない場合がありましたが、修正されました。
Version 5.61
(2004年6月5日)
  • 結合効率を計算する際に、ファイバ先端のウェッジ角を定義するためWDX,WDYコマンドを追加しました。 この機能は像面をティルトすることによってモデル化されていますが、WDX,WDYを使うことで、より簡便な定義が可能となります。
  • カム計算の結果がエクセルのファイルにエクスポートできるようになりました。
  • 最適化において、変数化したガラスをもっとも近接したカタログガラスに変換できるようにREGコマンドを拡張しました。 従来は屈折率およびアッベ数のオフセット値であるDNO,DVOを使って手作業でガラスを探す必要がありましたが、もはや、その必要はありません。
  • "Archer OpTx" 社のレンズカタログと新ガラスを OpTaliX のカタログに追加しました。
  • 選択されたガラスに対する、選択波長すべてにわたる dn/dT (屈折率の温度依存性)を、ユーザが求める温度において出力するようにLISコマンドが、拡張されました。(LIS DNDT コマンド)
Version 5.59
(2004年5月23日)
  • ズームレンズのカムの計算機能を追加しました。この機能により可動群の群間距離の関係が正確に解かれ、その結果がリストとして出力されます。 OpTaliX のこの機能は、単に面間隔を可変要素とする通常のズームレンズ(右図)に適用できるだけでなく、スキャン光学系のようにティルトやシフトなどを 多重構成パラメータとするような広義の "ズーム" レンズの可変要素の変化の仕方を関連づけられる、高度な汎用性を備えています。
  • 全径の開口サイズを実絞り径によって定義する場合、これまでは幾何的な倍率のみが考慮された近軸入射瞳径が用いられていましたが、 このバージョンからは瞳収差の影響も考慮された実瞳径を計算するように変更されました。
  • 自動設計において、"ユーザ指定の制約条件値" を "デフォルトの制約条件値" が上書きしてしまうという場合がありましたが、修正されました。
  • 開口サイズを実絞り径で設定した際、入射瞳径の計算に瞳収差の影響を考慮するように改良されました。
  • プライベートガラス(PRV)において、波長/屈折率のペアが6組よりも少ない場合には、屈折率補間が適切に行われない場合がありましたが、修正されました。
  • 光線追跡座標の決定法(Ray Aiming Method)としてテレセントリックを指定した場合にフットプリントのプロットが計算出力どおりに描かれませんでしたが、修正されました。
  • ファイバへの入射ビーム傾角がX成分を持つ場合の結合効率計算が正しく行われない場合がありましたが修正されました。
  • PIMがズームパラメータとして指定された場合は、面エディタの [PIM]チェックボックスにおける PIM計算の指定に優先して、常にズームパラメータとしてのPIMの指定が優先されます。 これを明らかに示すために、PIMがズームパラメータとして指定された場合には、面エディタの[PIM]チェックボックスを "グレイアウト" (灰色で表示して入力できないようにする)するように変更しました。
Version 5.55
(2004年4月25日)
機能追加、改良など:
  • EVA コマンドの出力に評価項目も付加しました。従来は数値結果だけの出力でした。
  • NAとNAO によって開口を設定した際、瞳が適切に定義できない場合がありましたが修正しました。
  • データベースアイテムに、XSC, YSC, ZSC (指定面の原点の座標。グローバル指定が併用されている場合は、グローバル座標系におけるローカル座標の原点座標)が抜けていました。これらを追加。
  • 最適化のための変数/制約条件エディタを起動すると、たとえRDXが変数化してあってもキャンセルされてしまう現象を修正。
  • NAとNAOが 1.0 を越えて受け付けられてしまい、OpTaliXが停止する現象を修正。
  • その他、細部の不具合修正および改良
Version 5.53
(2004年4月19日)
機能追加、改良など:
  • 最適化において、重み付き制約条件を指定できるようになりました(WTCコマンド)。
  • レーザダイオードように、非点収差を持つ光源にも対応しました(ASF,ASO コマンド)。
  • 環境解析のうち、環境温度の設定(TEM)機能に関連する計算上のヒステリシスが現れないように改良しました。
  • 照度解析の機能において、矩形状の物体が取り扱えるように改良されました。
修正された不具合:
  • OHARA社のガラスの比重が誤って登録されていましたが修正されました。
  • 対称性のあるホログラムに対して、回折次数の効果が近軸量の計算に反映されていませんでしたが、修正されました。
  • その他、細部の不具合を修正しました。
Version 5.52
(2004年4月18日)
機能追加、改良など:
  • 最適化において、重み付き制約条件を指定できるようになりました(WTCコマンド)。
  • レーザダイオードように、非点収差を持つ光源にも対応しました(ASF,ASO コマンド)。
  • 環境解析のうち、環境温度の設定(TEM)機能に関連する計算上のヒステリシスが現れないように改良しました。
  • 照度解析の機能において、矩形状の物体が取り扱えるように改良されました。
修正された不具合:
  • OHARA社のガラスの比重が誤って登録されていましたが修正されました。
  • 対称性のあるホログラムに対して、回折次数の効果が近軸量の計算に反映されていませんでしたが、修正されました。
Version 5.50
(2004年4月2日)
  • 実行時に必要とされるメモリを大幅に減少させました。とりわけ大きな瞳グリッド(NRD > 32)を指定した際に顕著です。
  • エンサークルドエネルギを数値でも得られるようになりました(ECE NUM コマンド)。これまでは図による出力だけでした。
  • 単光線に関する縦収差量を評価するためのコマンド、LAX, LAY が新設されました。
  • 1次収差を評価・出力するコマンドとして、FIR(近軸諸量の出力), FIO(近軸光線追跡結果の出力) が新設されました。
  • 光路差または波面収差を単光線について評価するためのコマンド、OPD, OPDWが新設されました。
  • レンズ断面図にプロットされる光線の本数に制約がなくなりました。従来はすべての画角に対する合計で500本でした。
  • 最適化における出力機能を強化しました。例えば、KT最適化における不等号制約条件に "cost" (負荷) が加えられました。
  • VIGP(ビネッティング評価)コマンドは、より汎用性の高い RIRR コマンドに置き換えられました。
    新コマンドは透過率を含んだ相対照度の計算を含みます。従来のVIGPコマンドは廃止されました。
  • OpTaliXが追跡光線を探査する際のアルゴリズムの厳密性を切り替えられるようになりました(RAIOコマンド)。 通常は従来どおりのアルゴリズム(通常モード: RAIO 1)で十分ですが、瞳収差の非線形性が強い、一部の超広角レンズ等では、 精密モード (RAIO 1)を指定することで、従来よりもパワフルな光線探査が実行されます。ただし、計算速度は低下しますからご注意ください。
  • レンズエレメントの体積/重量計算において、ホールや多角形形状が計算に折り込まれるようになりました。
  • 光学多層薄膜をレンズ面に貼り付けるコマンド ATT に、デフォルトの単層膜 (λ/4 の MgF2膜) を指定するオプション ATT DEF が追加されました。このオプションを使えば、膜データを作成することなく容易に単層膜付の光学系の全系透過率を計算できます。
  • 波面収差の計算結果から、"Zernike係数によってユーザ定義が指定する任意の波面" を差し引いて表示できるようになりました。(WAVZ command)
  • 照度解析の機能が面積物体を対象とするように改良されました。この結果、面積物体の結像特性をシミュレートするために 物面上において、複数の物点に対する結像特性をシミュレートする必要はなくなりました。またグラフィック出力も拡張されました (X/Y断面およびコンタープロットが加わりました)。 この機能は、メニューバーから [Geom.Analysis] → [Illminaion] の順にクリックして起動してください。

面積物体


面積物体の像:解析結果

Version 5.47
(2004年2月29日)
  • 光路図の出力の際、画角ごとに描画色を指定できるようになりました(下図ご覧ください)。
  • スポットダイアグラム、非点収差図、MTF図の出力の際、ズームポジションの選択を、各図のウインドウから簡単に選択するためのボタンが追加されました。 この機能は、従来より光路図や横収差図等に実装されていましたが、それら以外は、あらかじめ pos コマンドでポジションを選択しておかなくてはなりませんでした。
  • 最適化(自動設計)に、デフォルトの制約条件が追加されました。具体的にはレンズの中心厚、レンズ間隔、コバ厚(edge厚) が負にならないように自動的に制約条件が設定されます。
  • Zernike係数の番号が1ずつ繰り上がりました。このことにより、面形状や波面形状の取り扱いが、より一般的なものとなり、 CodeV との整合性も向上しました。OpTalXの従来版 (5.47よりも古い版)によって作成されたデータも、適切に読み込まれます。
  • Zernike係数への波面フィッティングにおいて、その残差が表示されるようになりました。この機能の追加により、 フィッティングに必要な項数の判定を明確な根拠のもとで行えるようになりました。
  • UDS/SPS 係数の設定エディタがモードレスウインドウになりました。この結果、このエディタを常時オープンしたままにでき、そこへの変更がただちに結果に反映させられるようになりました。
  • 照度ブロットの機能を再度、実装しました。
  • MANコマンドの出力に、吸収率を追加しました。
  • スポットダイアグラムを出力する際、スケールを示すマーカ(ボックス、クロス、エアリサイズの円など)を、スポットダイアグラムの前面に重ね描きするように変更しました。 従来はマーカをスポットダイアグラムの背景に描いていたため、場合によっては埋もれてしまい、見えなくなってしまっていました。
  • EIMDコマンド (拡がった物体に対する像評価) に関するOpTaliX内部のメモリ管理方法を改善しました。従来は一度確保したメモリ領域を逐次開放していませんでした。
  • その他、面の識別子の機能に若干の改良を加えました。
     

Version 5.45
(2004年2月15日)
  • 溶解ガラス(屈折率などの光学特性をユーザが定義するガラス)が吸収を取り扱えるようになりました。
  • "各面の透過率に対する寄与" 図において、吸収損失と反射損失の影響が示されるように改訂されました。従来はこれらを統合した結果だけが示されていました。
  • アサーマル(熱収差補正)に関連したガラスマップを提供します。この機能は色収差および熱収差 (温度による焦点位置のシフト)を同時に補正したシステムの開発に有効です。
  • ハイフンを含むガラス名(例: S-LAL18) をコマンドラインから入力すると、文法エラーが発生していましたが、解消されました。 このエラーは、OpTaiX がハイフンをマイナス記号だと誤認することによって生じていたものです。
  • プログラムの終了時、マクロエディタ中に記述されたマクロが保存されていない場合にも正しくセーブされるようになりました。以前は、単に空白文字だけが保存されていました。
  • マクロ中の #include 命令をひとつのOpTaliXプロセスで何度でも実行できるように改訂されました。
Version 5.44
(2004年2月7日)
機能追加:
  • 最適化の際、WTA (WeighT on Apertuer) の機能を使って光線収差に重みを付けられるようになりました。 重みは瞳座標の関数として表現されます。この機能を使えば、コントラストと解像力のバランスを制御できます。また、非点収差とコマ収差のバランスを制御できます。
  • いくつかの光学材料を、カタログに追加登録しました。
    赤外材料 IRTRAN1, IRTRAN2, MGO, MGO_IR, BaTiO3, AMTIR1
    オハラ社の低融点硝子
  • エンサークルド・エナジ(像面上に指定した直径内に到達するエネルギの割合) を求める機能が追加されました。 幾何光学的ベースで求める場合には ECG, 波動光学的な取り扱いによる場合はECEコマンドが使えます。
修正された不具合:
  • 物理光学的伝搬に関するマニュアルの説明が十分ではありませんでしたが、例を含めて充実した内容に改訂しました。 英語マニュアルはすでに完成しており今すぐ、ダウンロードして頂けます。日本語マニュアルは改訂中です。今しばらくお待ち下さい。
  • PSF XY断面が常に多色モードで表示されていましたが、単色/多色モードを正しく反映するように修正されました。
  • ツェルニケ エディタで面番号を指定すると、OpTaliXが異常終了する問題を修正しました。
  • オハラ社光学ガラスについて、内部透過率のデータが波長に対して逆順でカタログされていました。この問題は前バージョンである version 5.42でのみ発生していました。
Version 5.42
(2004年1月25日)
機能の変更・拡張など:
  • 最適化が実行不能な状態に陥ったとき、その原因をレポートする機能が拡充されました。具体的には、 最適化にあたって指定されたどの制約条件が実行不能な状態の原因になったかを、行番号と制約条件の定義式の両方で示します。
  • 面番号の指定の際、制約なく数式を使うことができるようになりました。例えば、"s3+4/2..i-2*3-5" は、"s5..i-1" に相当します。siは像面を意味しますから、 この場合は第5面から像面の手前の面(si-1) までを指定したのと同じ意味です。"s3+sqrt(4)" のように関数を使った表現も可能です。
機能の変更、不具合修正など:
  • GUIに関連した使い勝手の改良を行いました。
  • EDGコマンドで レンズ外径を指定した際に、体積・重量計算が正しく行われていませんでしたが、修正されました。
Version 5.41
(2004年1月12日)
機能の変更・拡張など:
  • OpTaliXの起動単位ごとに200までのプライベートガラスが扱えるように拡張されました。
  • 最適化の評価関数を外部ファイルに保存し、#include で取り込めるようになりました。 #include は、アイコンメニューから [var] をクリックするか、コマンドラインから var と入力すると開くダイアログに記述します。下記例をご覧ください。



    いったん #include を指定すると、以降は、外部ファイルを好みのエディタで修正・保存しアイコンメニューの [opt] をクリックするだけで、最適化を軽快に実行できます。
  • コーニング社の "Quantum Focus" Grin レンズを GUIから取り扱えるようになりました。
  • Primex (OPTIX Group) のニュートンゲージ(ニュートン原器)を追加しました。
  • レンズの外形寸法を指定した際(EDGオプション)、その値が面エディタの有効径の欄に表示されてしまっていましたが、表示されないように修正されました。 なお、この現象は表示だけの問題であって内部計算には影響を与えていませんでした。
Version 5.40
(2004年1月1日)
機能の変更・拡張など:
  • ユーザ定義屈折率分布面の機能を追加しました。この機能は、ユーザ独自の屈折率分布(GRIN)面を個別のサブルーチン(usergrin.dll)として記述することで、 その屈折率分布の追跡機能をOpTaliXにリンクできるというものです。
  • 設計変数の追加と削除のコマンド書式が変更になりました。OpTaliX の従来版では、例えば、"VAR sk +CUY" の要領で第k面の曲率を設計変数に加えていましたが、バージョン 5.40 からは "VAR sk CUY" のように + あるいは - 記号を使わない方法に改められました。設計変数の解除は、"DEL VAR sk CUY" の要領で行います。詳細はリファレンスマニュアル を参照してください。
  • 開口を指定するためのコマンド (例えば CIR, REX, REY など) が外形サイズを定義するためのオプション EDG に対応しました。 この情報はレンズ断面図の描画、体積・重量計算に反映されます。この結果、レンズ製造時のエッジ厚の検証や、鏡筒にあわせた断面図の描画などが簡便に行えるようになりました。
  • "広がった物体 ("Extended Object)" の結像状態を評価するコマンド EIMD が 入出力ともINTファイルに対応しました。 INTファイルによる物体定義の他、評価結果(結像状態)を INT ファイルまたは"生 (raw)" ファイルへに出力できます。従来はビットマップ形式 (BMP、PNG、PCX) からの入力だけしか扱えませんでした。
  • 個別のズームポジション、個別の視野に対するビネッティングを表示できるようになりました。また、これらを最適化の目標値(制約条件)として指定できるようになりました。 これに関連して、視野に渡るビネッティングの変化をプロットするためのコマンド名が "VIGP" に変更されました。
  • 設計変数の指定が、より厳密に行われるように改良されました。
  • YAN, YIM, YOB 等の視野情報を EVA コマンドで取得する際、たとえ 視野定義に使っていない項目であっても近軸的に変換した正しい値として取得できるようになりました。
  • 曲率半径よりもレンズ径の方が大きい面(平面取りのある面)のエッジが正しく描画されない場合がありましたがアップグレード権の更新を、OpTaliXの内部から行えるようになりました。 アップグレード権を更新して頂く際にお送りする "署名ファイル" をCドライブのルートディレクトリにコピーし、OpTaliX のメニューバーから、 [Help] → [Renewal Upgrade License] とたどっていただくだけです。従来はこの操作を行うには、独立した別プログラム(HLUPD.EXE)を必要としていました。修正されました。
Version 5.36
(2003年12月8日)
機能の変更・拡張など:
  • 自動設計用の変数として、新しく "GLA" を追加しました。この変数は、屈折率(DNO)と分散(DVO) を同時に変数としてして設定するものです。
  • Strehl関連のコマンドが、ズームポジションの指定を受け付けるようになりました。
  • 複数の波長に対する焦点距離EFL が、データベースアイテムによる参照の対象となりました。
  • 3次収差の定義をマニュアル中に明示しました。
  • LISコマンドで表示されるレンズデータに、物体面に関する情報が常に表示されるようになりました。これまでは無限共役の場合には表示は省略されていました。
  • コマンドラインからの文法解釈を厳密にし、誤解が生じないように改めました。これまでは式表現に空白文字が含まれることを許していましたが、そのことが、 複数のパラメータを空白で区切ることと混同してしまうケースがありました。今回の厳密化により、今後のバージョンでは式中に空白を挿入することは許されなくなりました。 ただし、()を使って式をくくる場合は、その限りではなく、従来どおり空白の挿入が許されます。
Version 5.34
(2003年12月1日)
新機能の追加:
  • スポットダイアグラムを構成する各光線の座標をファイルに書き出せるようになりました。
機能の変更、不具合修正など:
  • GUIの細部の使い勝手を改良しました。
  • 視野指定を YOB または YIM で行った場合、あるいは有限共役系において、3次収差(実収差の3次成分)の評価結果に不備がありましたが、この版で修正されました。
  • メニューバー直下のコマンドラインで [ESC]キーを押下するとコマンドラインそのものが消去してしまう不具合を修正しました。
  • "最小化"したウインドウを再起動した際、元あった場所に元どおりのサイズで復帰するように修正しました。旧版ではタスクバーに位置したままアクティブになるだけでした。
  • EMIDコマンドで起動するウインドウが、意味なく2度書きされる問題を解消しました。
Version 5.33
(2003年11月23日)
新機能の追加:
  • 最適化アルゴリズムに大幅な改良を加えました。新アルゴリズム"アクティブセット付DLS法 " はラグランジェの未定乗数法を内蔵することで 的確かつ緻密な等式制約条件処理を行います。また、不等式制約については、Kuhn-Tucker条件を判定条件とすることで、複雑な不等式条件下であっても 正しく極小解を見つけ出します。今般の改良により設計プロセスにおける解の収束速度が著しく向上しました。また従来のアルゴリズムでは探査が困難な高度な解、 つまり実現(製造)可能でかつ高い性能を有する解、にいっそう到達しやすくなりました。
  • 自動設計時のガラス境界をダイアログボックスから容易に編集できるようになりました。
  • ズーム光学系/多重構成光学系において、横収差をポジションごとに個別に表示できます。もちろん、すべてのポジションに渡る重ね描きも引き続きも従来に引き続き指定できます。
  • 中国製、および光ガラス製の光学ガラスをガラスマネージャから選択できるようになりました。
  • メインメニューへのアクセスに、キーボード・ショートカットを利用できるようになりました。
  • CodeV の seq 形式のデータを、IN コマンド および WRL コマンドでコマンドラインから直接読み書きできます。
  • SPS ODD (30次までの偶数/奇数混在多項式非球面)と SPS XYP (XY多項式による2次元自由曲面)について、 CodeVデータとの間で import export できます。
  • ISO 10110 図面において、テキストのサイズを変更できます。また、各レンズエレメントの大きさにあわせて、作図スケールを図面ごとに個別に設定できます。
  • アレイ面の定義において、 X および Y 方向のアレイグリッドの範囲を制限するためのパラメータ AMX,AMYパラメータを指定できるようになりました。 また、アレイセルの開口定義を通常のレンズ径の定義から分離しました。
機能の変更、不具合修正など:
  • Zernike係数が物理座標を反映した定義に変更しました。これまでは係数定義に対する単位円の直径を常に1に正規化していました。
  • 非球面サグ量の可視化ツールにおける面番号表示が正しく表示されるように修正しました。
  • SPS ODD 面における2次の非球面係数 (C3) を反映した焦点距離が得られるように修正しました。
Version 5.32
(2003年11月21日)
一部のテキスト出力と、図出力の書式変更等を実施したマイナー変更版です。
Version 5.31
(2003年11月19日)
新機能の追加:
  • 最適化アルゴリズムに大幅な改良を加えました。新アルゴリズム"アクティブセット付DLS法 " はラグランジェの未定乗数法を内蔵することで的確かつ緻密な等式制約条件処理を行います。 また、不等式制約については、Kuhn-Tucker条件を判定条件とすることで、複雑な不等式条件下であっても正しく極小解を見つけ出します。今般の改良により設計プロセスにおける解の収束速度が 著しく向上しました。また従来のアルゴリズムでは探査が困難な高度な解、つまり実現(製造)可能で かつ高い性能を有する解、にいっそう到達しやすくなりました。
  • 自動設計時のガラス境界をダイアログボックスから容易に編集できるようになりました。
  • ズーム光学系/多重構成光学系において、横収差をポジションごとに個別に表示できます。もちろん、すべてのポジションに渡る重ね描きも引き続きも従来に引き続き指定できます。
  • 中国製、および光ガラス製の光学ガラスをガラスマネージャから選択できるようになりました。
  • CodeV の seq 形式のデータを、IN コマンド および WRL コマンドでコマンドラインから直接読み書きできます。
  • SPS ODD (30次までの偶数/奇数混在多項式非球面)とSPS XYP (XY多項式による2次元自由曲面) について、 CodeVデータとの間で import export できます。
  • ISO 10110 図面において、テキストのサイズを変更できます。また、各レンズエレメントの大きさにあわせて、作図スケールを図面ごとに個別に設定できます。
  • アレイ面の定義において、 X および Y 方向のアレイグリッドの範囲を制限するためのパラメータ AMX,AMYパラメータを指定できるようになりました。 また、アレイセルの開口定義を通常のレンズ径の定義から分離しました。
機能の変更、不具合修正など:
  • Zernike係数が物理座標を反映した定義に変更しました。これまでは係数定義に対する単位円の直径を常に 1 に正規化していました。
  • 非球面サグ量の可視化ツールにおける面番号表示が正しく表示されるように修正しました。
  • SPS ODD 面における2次の非球面係数 (C3) を反映した焦点距離が得られるように修正しました。
Version 5.21
(2003年11月2日)
Optalixの品質とサービスの改善の一環として、今回アップデート方法を変更しました。新しい方法では、これまでの弊社サーバに代わり、ハードウェアキー(ドングル)によってライセンスの管理を行います。 したがって、今後はダウンロードの再に当社サーバアクセスにお使いになっていたユーザーアカウントおよび、パスワードは必要ありません。

新機能の追加:
  • 図面作成機能において文字サイズが適正に調整されるようになりました。
    また、レイアウトについても微調整を加えました。
  • 図面作成機能において、図面毎にプロットスケーリングを定義できるようになりました。これは、極端にエレメントの大きさが異なるレンズ系の図面作成時に便利です。
不具合修正:
  • 入射径より射出径の方が大きなテーパ−型ライトパイプをモデル化した場合に、プログラムが異常停止を起こす問題を解決しました。
  • 公差スプレッドシート内で設定したアッベ数公差が、ISO規格図面に正しく反映されていなかった問題を解決しました。
  • レンズデータ上で、面を新た挿入したり、削除した場合に、面データと公差データのリンクが保たれないという問題がありましたが、解決しました。
Version 5.18
(2003年10月12日)
新機能の追加:
  • インストーラが日本語対応になりました。
  • CodeVとのデータインポート/エクスポート機能が 面タイプ SPS ODD と SPS XYP にも対応しました。
  • ズームエディダがオープンしている状態でコマンドラインから追加のズームパラメータを入力すると、 それが直ちにエディタに反映されるようにエディタがリサイズされます。従来のバージョンはエディタ画面のスクロールが必要でした。
  • ズームとして定義していない光学系(いわゆる固定焦点光学系)に対してズームコマンド(例:"zoo thi s2 1 2 3") を入力した場合、 OpTaliXが自動的にズーム系に変換するようになりました。 新バージョンからは "ZOO npos" の指定が事前になくともデータは適切に入力されます。
不具合修正:
  • 最適化における目標関数の指定において、"si-1" の指定が正しく解釈されます。
  • CodeVのseqファイルのインポートにおいて、像面前に不要な仮想面が追加されなくなりました。
  • アップデートファイルのインストールにおいて、プライベートスペクトルが重ね書きされなくなりました。
Version 5.15
(2003年9月24日)
アレイ面(チャンネル面)の定義機能が拡張されました。新設の AMX および AMY を使えば、X と Y 方向のアレイグリッドの最大サイズをセットできます。 またこの定義は、"通常のレンズ開口" と "アレイ面の開口" のカップリングを解除します。
Version 5.14
(2003年9月12日)
新機能の追加:
  • シグマ光機のカタログレンズを収録しました。同社の型番を指定するだけで、そのレンズデータをすぐに利用できます。
  • ユーザ定義面 (UDS) を実装しました。この機能を使えば、ユーザ独自の面形状を定義し、DLLの形で OpTaliXに組み込めます。 FOTRAN言語とC言語によるサンプルソースコードも添付されました。複数のコンパイラに対応しています。
  • 奇数次を含む30次までの高次非球面に対応しました。
  • 10次までのXY多項式非球面に対応しました。
  • 計算速度が 10%〜15% 高速になりました。
  • 曲率半径のピックアップとは独立に、非球面のピックアップを指定できるようになりました。
  • 適正でないマクロ定義に対するエラー処理能力が向上しました。
  • ACCOS ファイルからの読み込み能力を向上し、種々のライブラリファイルに対応できるよになりました。
  • CodeVのプライベートガラスを読み込めるようになりました。
  • バグを修正しました。詳細はバージョン履歴を参照してください。
Version 5.12
(2003年8月31日)
新機能の追加:
  • シグマ光機のカタログレンズを収録しました。同社の型番を指定するだけで、そのレンズデータをすぐに利用できます。
  • ユーザ定義面 (UDS) を実装しました。この機能を使えば、ユーザ独自の面形状を定義し、DLLの形で OpTaliXに組み込めます。 FOTRAN言語とC言語によるサンプルソースコードも添付されました。複数のコンパイラに対応しています。
  • 奇数次を含む30次までの高次非球面に対応しました。
  • 10次までのXY多項式非球面に対応しました。
  • 計算速度が 10%〜15% 高速になりました。
  • 曲率半径のピックアップとは独立に、非球面のピックアップを指定できるようになりました。
  • 適正でないマクロ定義に対するエラー処理能力が向上しました。
  • ACCOS ファイルからの読み込み能力を向上し、種々のライブラリファイルに対応できるよになりました。
  • CodeVのプライベートガラスを読み込めるようになりました。
バグ修正:
  • 偏芯したアレイ面に対する光線が正しく描画できないという問題を解消しました。
  • 2波長だけを定義した光学系に対するMTFが正しく評価されていませんでしたが、このバージョンで修正されました。長波長側のMTFの寄与が正しく反映されていなかったためです。 この症状は2波長系でのみ現れていました。つまり、単色および3波長よりも多くを指定した光学系のMTFが正しく評価されていました。
  • マクロ表現において、1文字のキーワード (A, B, C, ... K等) が正しく解釈されない場合がありました。
  • 最適化においてデータベースアイテムを引用したメリット関数を構築する際、個別の各目的関数に付与した重みが、 時として目標値であるかのように解釈される場合がありましたが、修正を完了しました。
Version 5.11
(2003年7月20日)
  • GRIN材料に対する近軸逆光線追跡の不具合を修正しました。従来版はGRINレンズがミラー面の後方に配置された場合には正しく近軸量を計算していませんでした。
  • PSF X/Y コマンドによる 点像強度分布図のX/Y断面図プロットにおいて、正規化が正しく行われていませんでしたが、今回の改訂で修正されました。
  • 最適化機能において、目標関数の編集ダイアログボックスに全く定義のないまま[OK]ボタンを クリックするとOpTaliXが異常終了していましたが、今回の改訂で修正されました。
Version 5.10
(2003年7月13日)
  • ウインドウの構成を選択できるようになりました。各ウインドウを画面のどこにでも独立に動かせる "フローティング・ウインドウ" タイプ(従来タイプ)だけでなく、"インサイド・ルート "タイプを選択できます。右図に例を示しましたのでご覧ください。"インサイド・ルート "タイプは、各ウインドウの移動範囲がメインウインドウの内部に固定されますが、全体をメイン (ルート)ウインドウによって一括管理できます。 メインウインドウのメニューバーには新たに "Window" というメニューが追加されました。これを使えば必要とするウインドウをメニューから指定することで、最前面に表示されられます。
  • ミラー面を追加、あるいは削除するメニューが追加されました。これを使えばミラー面の後方空間の面間隔をマニュアル操作で逆符号にする操作から解放されます(OpTaliXが自動的に行います)。
  • ISO 図面における公差表示機能(面間隔と直径)が改良されました。
  • 製造メーカを指定して、ニュートンゲージの一覧表をプリントできます。
Version 5.07
(2003年6月11日)
  • 面アパーチャの自動調整機能が追加されました。
  • 面の修飾子に算術演算 (例:si-1, ss+2, s4..i-1)が使用できるようになりました。
  • マクロ・インタープリタが高速になりました。
  • マクロエディタを改良し、20個までのマクロファイルを同時に編集/実行できます。
  • プログラム立上げ時に、面エディタが自動的に開くようになりました。
  • スポットダイアグラムの表示スケール変更機能を追加しました。
  • 2次スペクトルのRMS値を計算する機能が追加されました。
  • 最適化ダイアログに"全変数削除"ボタンが追加されました。
  • 最適化実行中に、"ESC"キーで停止できるようになりました。
  • MODASバージョン4のファイルが変換入力できます。
  • SWISSOPTIC社の原器リストが追加されました。
Version 5.04
(2003年5月6日)
  • バージョン5.04は、GUIの僅かな不具合等を修正した定期更新版です。
  • ビーム伝播解析で、定義済みのファイバを使用できるようになりました。
Version 5.02
(2003年4月23日)
  • ファイバ結合効率計算において、マルチモードファイバを伝播する全てのモードが取り扱えるようになりました。
  • 面エディタが大幅に改訂され、ピックアップ機能/最適化変数/ソルブ機能等の編集が容易になり、また全体の設定も見やすくなりました。
  • 非球面を定義する多項式において、奇数次項が扱えるようになりました。
  • グラフィック表示の不具合(表示が2回繰返して更新されてしまう)が修正されました。
  • レンズカタログからの入力不具合(一部のレンズが正確に入力されない)が修正されました。
Version 5.01
(2003年3月30日)
  • 主光線ソルブ機能(UCY,HCY)が追加されました。
  • 新しい面タイプ"no-raytrace"が追加されました。その面では光線追跡をせずに、座標変換だけできます。
  • 新しい樹脂材料 ZEONEX 330R, E48R, 480R が追加されました。
  • 多数の望遠鏡の例が追加されました。( Pro/Edu のみ)
  • ノンシーケンシャル面の設定が容易になりました。
  • 最適化計算中の出力表示が改善されました。また、繰返し毎の結果出力が可能になりました。
  • QP最適化法における計算収束性が改善されました。